Airbrush Issue

J

jo3jo3520

Guest
Hello My name is Joe and Im basically brand new to the airbrush world and have stumbled upon an issue that I cannot seem to figure out. I purchased a Neo Iwata airbrush and it worked great for a few weeks and I cleaned it thoroughly or so I believed, but now when I try to use the airbrush paint no longer comes out! I broke it down and cleaned it inside and out including the nozzle. When the brush is connected to the compressor and has paint in the gravity feed you can feel lots of air coming from the tip but no paint. I had a cheap master brush in the beginning and the same thing happened so its obviously something im doing wrong but no clue =(. I thinned it and still no paint it spraying. Just doesnt make sense to me that with the needle drawn back that air comes out but paint does not. Any tips or help is greatly appreciated!
 
Hi and welcome to the forum,be prepare for your knuckles to be wrapped for not having a proper introduction in the introduction section!
It's always handy to know what paint your using, what your painting , it helps to speed up the process of narrowing the problem done.
The most obvious check to do is the actual needle pulling back when you pull the trigger back, that is, is the needle chuck nut done up tight?
The next most common cause is your brush just ain't clean enough, you might think it is but it most probably isn't. How do you clean it, what do you use?
 
I was using Createx paint and also Angelus acrylic paint. And sorry for not doing the Intro lol I will get to that ASAP! I think my issue may be exactly what JackEb said so I'm gonna take a Smaller needle and give that trick a shot. As far as cleaner I am using is Madea airbrush cleaner and also tried the Createx airbrush cleaner. Sorry so new to the whole airbrush world so I'll give everything a shot and see. The chuck was definitely tightened and needle was pulling back. Thanks for the help! I'll let you know results soon and get to the intro as well
 
@jo3jo3520 Check that the hole of the cap in your gun isn't blocked either - if it is clean the paint out so the hole is open. That could be part of the issue or the issue if it's not your tip.
 
It probably is a dirty nozzle :) I was a victim of this too. It really is surprising what can hide n there, especially after you think you have got it spotless. Even now when I think my nozzle is clean, I clean it again just for luck, and still get caught out now and then.


ctxPrimarySet.jpg
If you are using this paint, it probably isn't helping. This is a fabric paint, (although is used for other things) and is designed for brushes with .5 nozzles or above, spraying at very high pressure. The neo is .35(?) I think, so you will need a lot of reduction to get it to go through and get a good clean flow, and this is probably helping to block the nozzle. Even if you are getting it spotlessly clean, as soon as you put more paint in you will be fighting to get it through again straight away.

Not that you can't use it, but it is not ideal, especially when you are learning, and are trying to get to grips with other things. Try reducing it a lot more, or maybe upping your pressure - or both. But if it doesn't improve, and it's not a problem with the brush, then it might be an idea to consider other paints. Createx do other paint lines, and the pigments in these are ground much finer. Other paint brands that are popular are E'tac or Com-art, and a few others. If you decide to change, search the forum to find views on them, or just ask the question. If you mention the type of painting you want to do, you will get advice on paints to suit - just be warned, we all have our faves Lol.
 
image.jpg I paint on shoes that's why I was using Createx cause it said its good on leather and fabrics. Think I attached a pic of some cleats that I've done. They were originally solid green.
 
Could be a few things, you'll be amazed how many times people simply forget to tighten up their locking nut on the needle after a clean, done it a dozen times LOL and that also can cause this issue..try have a read through this guide, may help in the future and there is a specific section on the variables that can cause that issue and its generally just a case of checking each, best of luck..

http://www.airbrushforum.org/threads/airbrush-trouble-shooting-guide.2570/
 
So my problem was indeed a clogged nozzle! JackEb thank you for that initial help! Have 2 working airbrushes now lol. And RebelAir appreciate you sending that thread over I saved it to my home screen for the future
 
:D Glad to be of help. like you I was tearing my hair out thinking 'its clean'
now once I'm done for the day and the paint is out of the cup i'll run 2 x cups of water through, remove and wipe the needle down, then a small amount of restorer then water again. Thankfully I've not had the same issue since
 
Back
Top